Commit 53ddd4d2 authored by Cédric Ware's avatar Cédric Ware
Browse files

Allow building deb package for older systems.

parent e61b75ef
latex-theme-tpt (0.9.1-2) UNRELEASED; urgency=medium
* Make dependency on tex-common more explicit, override version.
-- Cedric Ware <cedric.ware@telecom-paristech.fr> Fri, 31 Jul 2020 15:50:00 +0200
latex-theme-tpt (0.9.1-1) UNRELEASED; urgency=medium
* Initial debian packaging.
......
......@@ -2,7 +2,7 @@ Source: latex-theme-tpt
Section: tex
Priority: optional
Maintainer: Cedric Ware <cedric.ware@telecom-paristech.fr>
Build-Depends: debhelper (>= 9.0.0), texlive-pictures (>= 2016), texlive-latex-recommended (>= 2016), texlive-latex-extra (>= 2016), fig2dev, latex-make, latexmk
Build-Depends: debhelper (>= 9.0.0), tex-common, texlive-pictures (>= 2016), texlive-latex-recommended (>= 2016), texlive-latex-extra (>= 2016), fig2dev, latex-make, latexmk
Standards-Version: 3.9.3
Package: latex-theme-tpt
......
......@@ -5,3 +5,10 @@
override_dh_auto_install:
$(MAKE) -f $$(pwd)/debian/packaging.mk prefix=$$(pwd)/debian/latex-theme-tpt/usr install-tex
$(MAKE) -f $$(pwd)/debian/packaging.mk prefix=$$(pwd)/debian/latex-theme-tpt-doc-fr/usr install-doc
# dh_installtex adds a dependency to the currently-installed tex-common
# version, but we may want to install the package onto older systems.
override_dh_installtex:
dh_installtex
perl -pi.orig -E 's{(tex-common\s+)\((.*?)\)}{$${1}(>= 6.06)}g' \
debian/*.substvars
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment